What are the minimum requirements for Enscape?


You need an NVIDIA or AMD graphics chip (OpenGL 4.2 compatible) with the recommended drivers. Supported products are NVIDIA GeForce GTX 460/Quadro 2000 and newer, as well as AMD Radeon HD 5000 series/FirePro W5000 and newer.

A fast CPU, like Intel i5 or better, is beneficial for the simulation of sound sources. You can reduce the quality of Enscape‘s graphics in settings. That way you can experience a smooth simulation on weaker systems as well.

Windows 7 SP1 (64 bit) or higher is required to run Enscape.

We currently do not support the following hardware:

Radeon 6000 mobile GPUs

Start typing and press Enter to search